Running Boards - Ford Truck Enthusiasts Forums

2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Running Boards

LinkBack Thread Tools Search this Thread
Old 05-30-2011, 04:39 PM
bridgerboy bridgerboy is offline
New User
Thread Starter
Join Date: May 2011
Posts: 7
bridgerboy is starting off with a positive reputation.
Running Boards

I have power running boards. I noticed that the paint is rubbing off on the spot I step on to get into the Expedition. Has anyone had this happen to them? Anybody know of a good fix?
Reply With Quote
Old 06-12-2011, 12:26 PM
shorning shorning is offline
New User
Join Date: Jun 2005
Posts: 4
shorning is starting off with a positive reputation.
Mine too

I just bought a 2008 and the same thing is happening on mine as well. I am wondering how I can touch it up.
Reply With Quote

Go Back   Ford Truck Enthusiasts Forums >

2004, boards, forumunning, lincoln, navigator, painted, running

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 12:01 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.