Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-12-2011, 03:10 PM
xikar xikar is offline
New User
 
Join Date: Apr 2011
Posts: 2
xikar is starting off with a positive reputation.
Burning smell when I start truck???

Hello everyone, I am new to the forum and it looks like a great place to find some helpful info for my SUV. I am having a problem with my 2008 Expedition Limited EL. The last couple of months my wife and I both notice a very strong burning smell inside the truck from the dashboard it seems every time we start the truck!!! We brought it to the dealer twice and while it was there it did not do it so they are at a loss. I am just curious if anyone else has experienced this type of problem and can offer some insight as to what is going on. The smell seems to be sort of like an electrical burning smell but also reminds me of like a break pad burning type smell. It only stinks right after we start it and then goes away within minutes. Anybody got anything?
Reply With Quote
  #2  
Old 04-14-2011, 12:58 PM
kennisonxgs kennisonxgs is offline
Junior User
 
Join Date: Oct 2008
Location: CA
Posts: 91
kennisonxgs is starting off with a positive reputation.
Do you smell it outside of the vehicle as well? Does it occur everytime you start or only when the engine is cold?
Reply With Quote
  #3  
Old 04-14-2011, 02:30 PM
xikar xikar is offline
New User
 
Join Date: Apr 2011
Posts: 2
xikar is starting off with a positive reputation.
Quote:
Originally Posted by kennisonxgs View Post
Do you smell it outside of the vehicle as well? Does it occur everytime you start or only when the engine is cold?
It's possible that it may smell outside the vehicle, I have to verify though, but it's very bad inside! Only happens on a cold start too we noticed.
Reply With Quote
  #4  
Old 04-15-2011, 05:37 PM
kennisonxgs kennisonxgs is offline
Junior User
 
Join Date: Oct 2008
Location: CA
Posts: 91
kennisonxgs is starting off with a positive reputation.
Could be an oil leak somewhere. Check your exhaust smoke during the cold start to see if it exhibits an unusual color.
Reply With Quote
Old 04-15-2011, 05:37 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2010, 73, 96, burn, burning, burnt, e350, electrical, f150, ford, freestyle, intake, smell, starting, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 04:54 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup