Power Running Boards WTF - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Power Running Boards WTF

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-11-2011, 07:01 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
Thread Starter
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Cool Power Running Boards WTF

Anyone ever have problems with the power running boards? Today I was getting out of the Expy and when the DS running board deployed it sound like it fell off. There is a big thud that shakes the truck everytime it opens. It opens and closes fine otherwise but its as if the very last 1" of travel it just falls down
Passenger side is fine, nice and quiet and smooth. Like I said this just started today.
Any suggestions???


Matt
Reply With Quote
  #2  
Old 04-12-2011, 04:17 PM
gpfarrell gpfarrell is offline
Senior User
 
Join Date: Nov 2004
Location: Pittsburgh!
Posts: 309
gpfarrell is starting off with a positive reputation.
Pray it's under warranty.

The driver's side board on my Navi got a little confused. It wouldn't close, or it would close and then re-open and then re-close as I drove away.

Very friendly local dealer fixed it under warranty. Would have been a 4-figure repair bill otherwise.
Reply With Quote
  #3  
Old 04-12-2011, 08:50 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
Thread Starter
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Quote:
Originally Posted by gpfarrell View Post
Pray it's under warranty.

The driver's side board on my Navi got a little confused. It wouldn't close, or it would close and then re-open and then re-close as I drove away.

Very friendly local dealer fixed it under warranty. Would have been a 4-figure repair bill otherwise.
Well its supposed to be covered by the ESP PremiumCare ( which is why I bought that plan ) so I should be OK but I was hoping to avoid having to bring it in.

Thanks anyway

Matt
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Power running boards - intermittent from 1 door only tomtoc 2007 - 2014 Expedition & Navigator 8 07-15-2016 05:24 PM
Delete rear muffler? Matt Mariani 1978 - 1996 Big Bronco 3 04-03-2015 10:17 AM
'04 Navigator Running Board Motor Starry Night Expedition & Navigator 3 08-27-2014 01:58 PM
King Ranch Exterior Care? STL King Ranch F-250 1999 to 2016 Super Duty 4 01-19-2014 10:38 PM
Running Board Subframe? Airslot Excursion - King of SUVs 9 12-22-2011 01:21 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2011, boadrs, board, boards, davidson, f250, ford, harley, power, problem, raptor, running, troubleshoot, truck, wire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 05:03 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.