Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 04-08-2011, 11:30 AM
m.tuba m.tuba is offline
New User
 
Join Date: Jan 2011
Posts: 11
m.tuba is starting off with a positive reputation.
window rolls down, but not back up

hello, long time listener, first time caller.

I have a 03 expediton, the window on the passenger side will roll down but will not roll back up, we replaced the motor but that wasn't it(realize now this was a hasty decison). We then tried taking the switch from the drivers rear door and swaped it with the passenger front, that didn't fix the problem. The switch from the passenger front works on the driver rear window though.

Any ideas on what the culprit is? btw i searched the tsb's and through 10 pages of the search, no luck

thanks in advance!
mike
Reply With Quote
  #2 (permalink)  
Old 04-08-2011, 02:15 PM
jeebie's Avatar
jeebie jeebie is offline
New User
 
Join Date: Feb 2011
Posts: 21
jeebie is starting off with a positive reputation.
Our 06 does the same thing although it is hit and miss right now on whether it will go back up. I just use the driver side if it won't go up. My hubby thought it was the switch but maybe not.
Reply With Quote
  #3 (permalink)  
Old 04-08-2011, 02:55 PM
Z06PSI's Avatar
Z06PSI Z06PSI is offline
Senior User
 
Join Date: Dec 2008
Posts: 155
Z06PSI is starting off with a positive reputation.
What about the regulator? or is it combined with the motor? I am unsure.
__________________
Andrew, Christine, and Aidan Baker
2005 Navigator Ultimate
2002 Mil Yel ZO6 - 383 stroker 2.8L Kenne Bell and methanol.
Reply With Quote
  #4 (permalink)  
Old 04-08-2011, 03:26 PM
RedHorse1 RedHorse1 is offline
Senior User
 
Join Date: Jan 2006
Posts: 213
RedHorse1 is starting off with a positive reputation.
The regulator and motor are separate pieces. I've had to replace both front regulators on my '03. My symptoms sound a little different to yours tho. Up and down were both slow and I could hear a grinding sound. Eventually it wouldn't go up at all without help. Not a big job to replace. Search for "yardbird", he posted an excellent how-to with pics on the regulator replacement. It's several years old now but you should be able to find it.
Reply With Quote
  #5 (permalink)  
Old 04-08-2011, 04:31 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,047
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by m.tuba View Post
we replaced the motor but that wasn't it(realize now this was a hasty decision).
If the motor works to run the windows down, then it's not bad...right?

Replace the master switch in the driver's door. The power and control wiring first runs through it, then it goes on to the other door switches.

You might try beating on the front passenger switch in the driver's door to see if you can make the window go up. This would at least confirm the switch is the problem.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #6 (permalink)  
Old 04-08-2011, 05:50 PM
m.tuba m.tuba is offline
New User
 
Join Date: Jan 2011
Posts: 11
m.tuba is starting off with a positive reputation.
Yeah, thanks alloro, my buddy bought the motor before he go me involved.

we cleaned the contacts in the drivers side door switch, it works now, you just have to push hard and it'll go up,
Reply With Quote
  #7 (permalink)  
Old 04-09-2011, 07:50 PM
RedHorse1 RedHorse1 is offline
Senior User
 
Join Date: Jan 2006
Posts: 213
RedHorse1 is starting off with a positive reputation.
I remember a post on how-to clean the window switches.
http://www.ford-trucks.com/forums/87...ow-switch.html
Check this link out.
Reply With Quote
  #8 (permalink)  
Old 04-10-2011, 09:21 PM
cdherman cdherman is offline
Posting Guru
 
Join Date: Jun 2003
Location: Parkville, MO (KC)
Posts: 1,217
cdherman is starting off with a positive reputation.
To clarify: It goes down with power, and then?
a) no motor at all going up?
b) motor groans to a stop?
c) creaking, squeaking occurs and it stops?

a) bad switch, somewhere
b) just like mine, tracks need to be cleaned and lubed, silicone the rubber parts. Ford did not get this one just right. Many others have same problem..
c) possible b), but also could regulator or cables messed up.

If its any consolation, I too replaced the motor, only to find that it was the same afterwards....
__________________
1965 F100, 240 I6, 4pd T-18, swapped to C4, Pertronix, Front Disk Swap, PS Upgrade. Bought by my dad when I was 6 months old. 2004 EB Expedition for towing.
Reply With Quote
  #9 (permalink)  
Old 04-10-2011, 11:08 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,047
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Quote:
Originally Posted by cdherman View Post
To clarify: It goes down with power, and then?
a) no motor at all going up?
Do you think that maybe next time you might try and read the thread before posting? The problem was solved. It turned out to be the driver's master switch.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #10 (permalink)  
Old 04-06-2012, 04:40 PM
ljackson911 ljackson911 is offline
New User
 
Join Date: Sep 2011
Posts: 2
ljackson911 is starting off with a positive reputation.
lesjackson911
Possible Alternate problem to look for.

I know this user has solved the problem, but I wanted to add my 2 cents, as I used this thread to help solve the problem. I went step by step thru this thread to fix RR window not rolling up. Found that it was a dirty contact in the drivers master switch. Put it all together only to find that the window still wouldn't roll up using the RR switch. That's when I noticed that the small plastic post that actuates 'up' had literally melted off. Electrical works fine. Anyone have any insight into what causes this? ('01 SuperCrew)
Reply With Quote
  #11 (permalink)  
Old 04-07-2012, 05:15 PM
m.tuba m.tuba is offline
New User
 
Join Date: Jan 2011
Posts: 11
m.tuba is starting off with a positive reputation.
I have an 05 super duty that also had the same problem with the switch as your super crew, and needed the switch replaced. I think that the switch gets hot from the bad connection and melts the internals. That's my opinion
Reply With Quote
  #12 (permalink)  
Old 04-09-2012, 12:05 PM
ljackson911 ljackson911 is offline
New User
 
Join Date: Sep 2011
Posts: 2
ljackson911 is starting off with a positive reputation.
lesjackson911
@m.tuba... Did you experiment at all with cleaning the contacts before you replaced the switch? Wondering if it's worth the effort.
Reply With Quote
  #13 (permalink)  
Old 04-09-2012, 05:29 PM
m.tuba m.tuba is offline
New User
 
Join Date: Jan 2011
Posts: 11
m.tuba is starting off with a positive reputation.
No, on the super duty, when I disassembled the switch it was too far gone and just replaced the switch
Reply With Quote
  #14 (permalink)  
Old 07-21-2012, 11:11 AM
jampen jampen is offline
New User
 
Join Date: Aug 2011
Posts: 4
jampen is starting off with a positive reputation.
I fixed this problem

2004 F250 Crew Cab SuperDuty, 6.0 Diesel

Passenger side window would roll down but not back up and there were no sounds coming from motor or door when I tried to roll it back up.

$123 replacement switch panel from local parts depot. Popped the old one out, unplugged 4 power plugs from bottom of units, popped new one in.

Everything worked fine. Easy fix except for the cost of the part.

This is what I bought

http://www.switchdoctor.net/ford-win...m-4-door-.html
Reply With Quote
Old 07-21-2012, 11:11 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
2002, back, explorer, fine, flex, ford, power, pwer, rear, roll, rolls, sport, trac, window, wont, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup