Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs
Sign in using an external account
Register Forgot Password?


Excursion - King of SUVs 2000 - 2005 Ford Excursion

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-17-2011, 06:25 PM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
I've had it with these Body Mounts!!

Is there anything else I can do?

That body mount noise is finally getting to me. I feel like driving the EX into a palm tree sometimes, but then remember that I would probably just drive through it with little damage!

Things i have done:
1) I replaced at Ford at 100,000 miles, No Lube (lasted about 30k)
2) I loosened up the mount and lubed it (lasted about 1 month)
3) I tightened the hell out of it instead of the normal 82-87 lbs (lasted about 2 weeks)
4) Had it removed, took shaft to the grinder took off 1/8 in on each side. (lasted about 1 month)

This is the mount on Drivers side. All Others are tight, no noises and no sign of body movement.

My question is, has anyone tried something else that has helped?
Maybe a different body mount? Maybe a different manufacturer?

Your ideas are greatly appreciated.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #2  
Old 03-17-2011, 08:07 PM
Gfisher Gfisher is offline
Freshman User
 
Join Date: Dec 2010
Location: Grand rapids
Posts: 30
Gfisher is starting off with a positive reputation.
I hate that squeak!No help though I'll be checkin back.
Reply With Quote
  #3  
Old 03-17-2011, 10:19 PM
UrbanXX's Avatar
UrbanXX UrbanXX is offline
Posting Guru
 
Join Date: Sep 2008
Posts: 2,491
UrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputation
Man I know where you are comming from.

How to tell if you need body mounts.
Try to replace a front turn signal bulb. If you can't see the bottom phillips head screws for tha assebbly then the body has sunk or the body mounts have colasped. The bottom screws will be slightly below the top edge of the bumper.
I'm thinking about replaceing mine, but it looks like a lot of work.
Reply With Quote
  #4  
Old 03-17-2011, 10:44 PM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
Unfortunately Ford does not have a complete kit, so each one is about $90.00 (needing 12 i believe) and labor is about a full day to lift body off frame, replace mounts and put interior back together . That is a ton of money! I would do it but i think if it did not give me at least two years i would just loose it!

My teenage daughter has suggested new sound system, rub some dirt in it, suck it up, etc.

Would hate to go that route, will see.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #5  
Old 03-17-2011, 10:51 PM
UrbanXX's Avatar
UrbanXX UrbanXX is offline
Posting Guru
 
Join Date: Sep 2008
Posts: 2,491
UrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputationUrbanXX has a superb reputation
We had a thread somewhere on this before and seems like somebody found them aftermarket for about 20.00 a piece. I think the first 2 sets on the front are the ones that go first.
Reply With Quote
  #6  
Old 03-17-2011, 11:46 PM
AlaskanEx's Avatar
AlaskanEx AlaskanEx is offline
Post Fiend
 
Join Date: Apr 2009
Location: Anchorage Alaska
Posts: 9,584
AlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputationAlaskanEx has a superb reputation
i've heard is this issue but not had it in any of my 3 excursions...fingers corssed!
__________________
Russ-
2011 F-150 Limited #3679 6.2 V8 4x4, Retrax bed cover, Husky mud flaps and wheel liners, HIDs, 35% tint
2002 Excursion Limited V10 4x4, 2.5/2" lift, HIDs,LEDs,20" DC wheels
1998 Expedition XLT 5.4 4x4,HIDs,16x8 ultra wheels,LEDs, HIDs
1991 F-250 lairat 4x4 5.0, 7'6" BOSS snow plow, Back Rack, Strobes, Work lights
Reply With Quote
  #7  
Old 03-18-2011, 12:07 AM
wallz's Avatar
wallz wallz is offline
Postmaster
 
Join Date: Jan 2008
Location: The Great White North!
Posts: 2,501
wallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud of
Quote:
Originally Posted by LivingLarge View Post

My teenage daughter has suggested new sound system, rub some dirt in it, suck it up, etc.

Would hate to go that route, will see.

I'm sure she would love for you to go this route.

Mine gets off road duty so I learn to ignore or just crank the tunes higher when I start hearing all the kreeking noises from underneath. Now that I have finished my new stereo I have more reason to enjoy the tunes cranked.
Reply With Quote
  #8  
Old 03-18-2011, 04:39 AM
loleuiha's Avatar
loleuiha loleuiha is offline
NEWBIE BUT PREMIUM
 
Join Date: Sep 2006
Location: SAN JOSE CA
Posts: 111
loleuiha is starting off with a positive reputation.
I have been wondering what that squeaking noise is when I drive. It sounds like a squeak rattle combination kind like the sound of a piece of paper flapping real fast at a high pitch. Is that the sound from a worn body mount?

Loleuiha
__________________
LoleUiha

2000 Ford Excursion Limited 6.8 V-10
4X2.
Reply With Quote
  #9  
Old 03-18-2011, 06:01 AM
3fingervic 3fingervic is offline
Freshman User
 
Join Date: Feb 2011
Posts: 42
3fingervic is starting off with a positive reputation.
Other than the annoying sound, is there a real problem? BTW, I get a strange sound when I stop, is that the springs flexing?
Reply With Quote
  #10  
Old 03-18-2011, 08:04 AM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
Quote:
Originally Posted by AlaskanEx View Post
i've heard is this issue but not had it in any of my 3 excursions...fingers corssed!

Maybe that Alaskan Mud is helping you out. Your lucky you don't have to deal with. It sucks!

Truck still looks like a $40,000 Ride
Truck Runs like a $40,000 Ride
When creaking noise starts
Truck feels like your driving a $400 clunker.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #11  
Old 03-18-2011, 08:09 AM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
Quote:
Originally Posted by UrbanXX View Post
We had a thread somewhere on this before and seems like somebody found them aftermarket for about 20.00 a piece. I think the first 2 sets on the front are the ones that go first.

I would probably just replace the 2 under the front floor board area, if i need to go original. I just would hate to have them all done.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #12  
Old 03-18-2011, 08:13 AM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
Quote:
Originally Posted by 3fingervic View Post
Other than the annoying sound, is there a real problem? BTW, I get a strange sound when I stop, is that the springs flexing?
Sounds like you have the same problem, noise seems like it comes from rear of front springs, but its the body mount. Its not a safety problem.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #13  
Old 03-18-2011, 08:18 AM
LivingLarge's Avatar
LivingLarge LivingLarge is offline
Postmaster
 
Join Date: Feb 2011
Location: Ft. Lauderdale, FL
Posts: 3,193
LivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputationLivingLarge has a superb reputation
Quote:
Originally Posted by loleuiha View Post
I have been wondering what that squeaking noise is when I drive. It sounds like a squeak rattle combination kind like the sound of a piece of paper flapping real fast at a high pitch. Is that the sound from a worn body mount?

Loleuiha

Its more like a creaking sound, usually when you stop or sometimes if you takeoff fast, they progressively get worse to the point they can make noises when turning into driveways or hitting a large bump etc.
__________________
Michael
05 LTD 4x4, PSD, ARP, Tuner, Cat Delete, K&N CAI,4" Exhaust w 6" SS Tip, 5" Lift, air bags & RAS, 35's Terra Grapplers on Fuel Wheels, Bilstein 5100's with Dual stabilizers, Twin air, train horn, Amp Research, Rigid Industries, F&R Mag Hytec, Pioneer Nav, 2010 OEM mirrors, DC 270 amp, Blue spring, much more...02 LTD 4X4, V10 Sold
"I bought a 6.0 PSD and I'm not afraid"
Reply With Quote
  #14  
Old 03-18-2011, 09:06 AM
CrzHelm's Avatar
CrzHelm CrzHelm is offline
Senior User
 
Join Date: Oct 2010
Location: Long Island NY
Posts: 210
CrzHelm is gaining momentum as a positive member of FTE.CrzHelm is gaining momentum as a positive member of FTE.
Had a squeak on mine everytime i stopped or left. It turned out to be the leaf spring shackle. I rounded the bolt a few turns with silicone spray and problem gone.
__________________
2000 Excursion limited 6.8l v10,
Mods: 6" procomp lift, rough country dual steering stabilizers, 35x13.50 mickeythompson atz on 20x10 Mamba m4's, rs9000 shocks.
http://i56.tinypic.com/213qlht.jpg
Reply With Quote
  #15  
Old 03-18-2011, 09:36 AM
CanadianSmokie's Avatar
CanadianSmokie CanadianSmokie is offline
Elder User
 
Join Date: Oct 2007
Location: Nova Scotia
Posts: 783
CanadianSmokie is gaining momentum as a positive member of FTE.CanadianSmokie is gaining momentum as a positive member of FTE.
I keep hearing the sound described as a sqeak but I get this deep, clunk sound... like something in the suspension loading up and then releasing. I've had the front end checked over numerous times to try and identify it but everything is tight. Could think occasional clunking sound be the mounts? Does anyone else have this deep rubbing/clunking?
__________________
Ken

Ratt X

2001 7point3 PSD
All Go...No Show
Reply With Quote
Old 03-18-2011, 09:36 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nice Grinding noise coming from the driver side...help? zacm7 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 11 05-09-2014 02:08 PM
Bonehead move today with my FX4 Pool Runner 2009 - 2014 F150 22 12-23-2013 12:44 AM
squeak pop under drivers feet bigbugman Excursion - King of SUVs 11 04-21-2009 09:23 PM
Wheel seals are squeaking brown 4x4 1987 - 1996 F150 & Larger F-Series Trucks 10 03-12-2008 01:43 AM
Squeeeeek! Jolly Mon Super Duty & Heavy Duty 7 05-17-2002 11:30 AM


Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs

Tags
1996, 2002, bodies, body, bolts, excursion, explorer, f250, fix, ford, mount, mounts, noisey, rear, replace, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup