Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-08-2011, 09:42 PM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
Repairing FICM harness connectors

Trying to do a bunch of stuff to rule out problems before I may have to face up to an injector (engine knocks, especially when rpms drop as engine goes into 5th gear.)

One FICM connector was broken and tried a zip tie repair. Didn't work.

Click the image to open in full size.

I found these 3 replacement connectors. Each is $30+/-.
Anybody know which is which? Are they for X1, X2 & X3?
Has anybody done the swap? Looks like it could be a royal pain.

2003-2009 International VT365 FICM Connector part ap0018
2003-2009 International VT365 FICM Connector part ap0019
2003-2009 International VT365 FICM Connector part ap0020


Then I find 3C3Z-9D930-AA for $71.
Is this the whole FICM harness? I can't get a picture.

Is 3C3Z-12B637-BA the whole harness? I see that for $240.

I can't find a good photo or description of these items online and I can't get down to dealer parts dept for a few days.
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
  #2  
Old 03-08-2011, 09:57 PM
mrwrench mrwrench is offline
Senior User
 
Join Date: Mar 2004
Location: urbana il
Posts: 325
mrwrench is starting off with a positive reputation.
change the harness > ebay $90
__________________
juan
Reply With Quote
  #3  
Old 03-08-2011, 10:18 PM
High Binder's Avatar
High Binder High Binder is offline
Posting Guru
 
Join Date: Sep 2009
Posts: 1,441
High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.
Which part is broken? It looks like the clip from the male portion is still there.

I've seen a lot of connectors that have turned green from corrosion and lost continuity because of the corrosion, could that be your problem?
__________________
Masters in Mechanical Engineering/Chem minor. 6.5yrs Caterpillar R&D but currently pursuing law degree (patent law). Member ASME & student member STLE & SME.

2004 F350 6.0. Lariat FX4. Other assorted cars/bikes.
Reply With Quote
  #4  
Old 03-08-2011, 10:36 PM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
I really don't know what the problem is. I don't have scan equipment or code reader tool yet ... although tax rebate comes in soon!!

The truck has no CEL and starts fine. Then it shakes at idle. Shake somewhat noticeable when driving. Shake EXTREMELY noticeable when speed is around 45mph and rpm's drop back to 1,100ish ... so I guess it's going into 5th.

Took everything apart again today. All pins were fine and connectors were clean. This was the only thing I could point to.

Rev-X is on its way in the mail as we speak. I hope that may help. Right now the truck is a giant paper weight.

Does a FICM loose it's programing if it sat around disconnected from the vehicle for about 2 weeks in the cold?
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
  #5  
Old 03-08-2011, 11:09 PM
iduger iduger is offline
Senior User
 
Join Date: Mar 2008
Posts: 114
iduger is starting off with a positive reputation.
Go on ebay entire ficm harness 100.00. or try salvage yard found mine 25.00.
Reply With Quote
  #6  
Old 03-08-2011, 11:15 PM
m-chan68's Avatar
m-chan68 m-chan68 is offline
Postmaster
 
Join Date: Mar 2010
Location: Brampton, Ontario, Canada
Posts: 3,070
m-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant futurem-chan68 has a brilliant future
Quote:
Originally Posted by Piolet View Post
Click the image to open in full size.

Then I find 3C3Z-9D930-AA for $71.
Is this the whole FICM harness? I can't get a picture.
3C3Z-9D930-AA is the whole FICM harness, which includes the connectors to all eight injectors, the two main connectors to the FICM (cylinders 1, 4, 6 & 7 and cylinders 2, 3, 5 & 8) and the main FICM ground eyelet on the rearmost intake manifold stud on the driver side.

Is 3C3Z-12B637-BA the whole harness? I see that for $240.
3C3Z-12B637-BA is the entire engine harness that connects everything together on the engine, which includes the following: A/C compressor clutch switch, the green and black GPCM connectors, the main positive lead to the passenger side battery, the alternator connector as well as the positive terminal, the EOP & EOT, the VGT, IPR & ICP, fan clutch, EGR valve, ECT, EBP (even though it's useless on 2003 engines), IAT #2, the third FICM connector, the middle PCM connector, the two main connectors to the frame harness and last but not least, the CKP & CMP. By the way, for $240 that's cheap.
I hope the text in red is helpful enough.
__________________
http://www.yorkdaleford.com/service.html[/url]
Ford Diesel/Senior/Master Tech
....who works at a dealership that now employs SOME half decent looking female employees since they overhauled most of the administrative staff
....but STILL loves hot women with big boobies
....and STILL hates working on E-Series with 6.0L
Reply With Quote
  #7  
Old 03-08-2011, 11:35 PM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
Thank you Sir!!
Huge help!
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
  #8  
Old 03-08-2011, 11:40 PM
High Binder's Avatar
High Binder High Binder is offline
Posting Guru
 
Join Date: Sep 2009
Posts: 1,441
High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.
Quote:
Originally Posted by Piolet View Post
I really don't know what the problem is. I don't have scan equipment or code reader tool yet ... although tax rebate comes in soon!!

The truck has no CEL and starts fine. Then it shakes at idle. Shake somewhat noticeable when driving. Shake EXTREMELY noticeable when speed is around 45mph and rpm's drop back to 1,100ish ... so I guess it's going into 5th.

Took everything apart again today. All pins were fine and connectors were clean. This was the only thing I could point to.

Rev-X is on its way in the mail as we speak. I hope that may help. Right now the truck is a giant paper weight.

Does a FICM loose it's programing if it sat around disconnected from the vehicle for about 2 weeks in the cold?

Kinda sounds like an ICP issue with the shaking at speed. Mine did a little jerking around 60-70mph and the new ICP fixed that.

The ficm (unless something else happened) will keep it's program.

Rev-X will help if it's an injector problem but it's just a band-aid. I run it and love it but I know it's just a matter of time before I'm back into it putting in new injectors.
__________________
Masters in Mechanical Engineering/Chem minor. 6.5yrs Caterpillar R&D but currently pursuing law degree (patent law). Member ASME & student member STLE & SME.

2004 F350 6.0. Lariat FX4. Other assorted cars/bikes.
Reply With Quote
  #9  
Old 03-08-2011, 11:53 PM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
Quote:
Originally Posted by High Binder View Post
Kinda sounds like an ICP issue.
That's what started all this. I just replaced the ICP and connector.
The oil leak's gone and the rpm's have settled down.
Maybe I messed up splicing the connector

Boy that would suck. Hopefully its sunny on Saturday.
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
  #10  
Old 03-09-2011, 12:00 AM
High Binder's Avatar
High Binder High Binder is offline
Posting Guru
 
Join Date: Sep 2009
Posts: 1,441
High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.High Binder has a good reputation on FTE.
Quote:
Originally Posted by Piolet View Post
That's what started all this. I just replaced the ICP and connector.
The oil leak's gone and the rpm's have settled down.
Maybe I messed up splicing the connector

Boy that would suck. Hopefully its sunny on Saturday.

?Maybe. You mentioned that you don't have a scanner so it's going to be hard to tell. I watch my ICP on my scangauge to make sure it's reading but I don't know if there is a trick to figuring out if it's reading without a scanner???

May be time to get a scangauge and see where it's at. I dunno but your symptoms sound like mine when I had the ICP going out. I got a scanguage off Amazon.com for $200-ish (don't remember exactly) but it was one of the best buys I've ever made for a car.
__________________
Masters in Mechanical Engineering/Chem minor. 6.5yrs Caterpillar R&D but currently pursuing law degree (patent law). Member ASME & student member STLE & SME.

2004 F350 6.0. Lariat FX4. Other assorted cars/bikes.
Reply With Quote
  #11  
Old 03-09-2011, 06:30 AM
bismic's Avatar
bismic bismic is offline
Post Fiend
 
Join Date: Nov 2003
Posts: 14,543
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
I can't recall - I assume your truck is an '03 or early '04?
__________________
Mark
06 F250 CC SB FX4 Lariat;ARP studs;OEM gaskets;Banks exhaust;DynaTrac Ball joints;Coolant filter;High-Idle mod;RACCCV6000;JimmiJammers;Ravelco;SynchroMax xfer case;Fumoto valve;Harpooned;CPOhighwayProducts toolbox;tracrac;Fox Weatherboots;Wet Okole Seat Covers;BriteBox;Re-flashed;Quadzilla Recon XZT Fuel Press;Blue FPR spring;DashDAQ;PHP FICM;RiffRaff boots;DCPower270AXP;PowerInverter;Rancho7000's;BPD EGR cooler;One-piece HPOP fitting;D-plugs&standpipes;BPD BilletWaterPump;SCT w/ Matts SRL+;ELC Ultra;DuraTracs
Reply With Quote
  #12  
Old 03-09-2011, 08:41 AM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
Early '03. ICP at rear of engine.

I'll shameless plug my last overly descriptive post on this ...

http://www.ford-trucks.com/forums/10...placement.html
..... this is the full story.

If an injector(s) didn't just stick or fail over night then I think I must have messed something up I guess. Maybe I was too rough with the harness when I had it pulled back to do the splicing.

This weekend I'm going to splurge on an Edge insight CTS.

I hate posting without being able to supply parameters. Plus it'll finally give me some of the gauges I should be viewing too.

Any help or suggestions appreciated.
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
  #13  
Old 03-09-2011, 12:21 PM
rocky1074's Avatar
rocky1074 rocky1074 is offline
Elder User
 
Join Date: Aug 2009
Location: Inverness, Fl
Posts: 905
rocky1074 is gaining momentum as a positive member of FTE.rocky1074 is gaining momentum as a positive member of FTE.
Parts guy ed has the FICM Harness 3C3Z-9D930-AA 70.87

www.partsguyed.com
__________________
Rocky
2003 F-350 SD 6.0 Crew Cab DRW; Early Built 5/03; Diesel Site
Coolant Filter; High Idle Mod; 24" Wipers; Prodigy Brake Controller; Fumoto Valve; ZooDad; Magnefine PS Filter; Edge Insight w/EGT Probe.
2007 Harley Ultra Classic Electra Glide

Reply With Quote
  #14  
Old 03-11-2011, 11:42 PM
Piolet's Avatar
Piolet Piolet is offline
Posting Guru
 
Join Date: Oct 2006
Location: Francestown, NH
Posts: 1,542
Piolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to beholdPiolet is a splendid one to behold
Talking Working again!!

Problem solved.

Spent a good hour today online trying to price harnesses, or connectors, looking to get a scan tool, thinking I'd have to get injector(s), trying to figure out how I might pay for it all. Feeling pretty down.

Went outside to redo my work just one more time, just in case, and found the connector on the injector closest to the firewall wasn't on properly

Thankfully the clip was still on it.

Plugged it in and now it runs just fine. ICP done! 3 weeks later!!!
__________________
Colm
2003 SuperDuty 6.0L 4x4 CC SB - 333,000 miles - Rolled off the line 02/20/2003 - 17mpg
1997 Explorer 4.0L 4x4 6V OHV - 172,000 miles
Due to recent budget cuts the light at the end of the tunnel will be turned off until further notice.
Reply With Quote
Old 03-11-2011, 11:42 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
International 444 Door Badges '94IDITurbo7.3 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 15 08-16-2012 05:22 AM
Replacing damaged FICM connectors...A HOW-TO with pics fixxxer-upper 6.0L Power Stroke Diesel 23 01-09-2012 08:23 PM
Alliant Power Oil Cooler? jflo631 6.0L Power Stroke Diesel 8 10-08-2011 05:18 PM
VT 365 is a long way from a powerstroke brickie 6.0L Power Stroke Diesel 10 01-26-2009 10:14 AM
Latest info on flashes and wire chafing emtabmm 6.0L Power Stroke Diesel 13 01-01-2004 09:22 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel

Tags
12b637, 30, 3c3z, 3c3z12b637ba, 60, ba, broke, broken, connector, connectors, ficm, ford, harnesses, international, pin, pins, repair

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup