Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-28-2011, 01:18 PM
Chuggster Chuggster is offline
Freshman User
 
Join Date: Sep 2010
Posts: 45
Chuggster is starting off with a positive reputation.
Power tilt does not work and won't shift from park

A few days ago the power tilt quit working on my 07 Nav. And just yesterday I had problems getting it out of park a few times. I kept trying and eventually it would not go at all. I hit the brake and the lever on the shift **** will not go in to shift into gear. It runs and starts fine. I had to take the little cover off by the shifter and push the little button down to override it to shift into drive. I can not find anything wrong so far. When I pull the lever on the shift **** I can hear a switch or relay in the steering column click. Is there a relay that controls the power tilt and the shifter?
Reply With Quote
  #2  
Old 02-28-2011, 01:52 PM
Chuggster Chuggster is offline
Freshman User
 
Join Date: Sep 2010
Posts: 45
Chuggster is starting off with a positive reputation.
I just found that the brake lights are not lighting up. I hit the brakes over and over and finally when they lit up it would shift to drive. But then when trying again the brake lights do not light. I checked 2 fuses under the hood that were for the brake lights and they were good. Please help.
Reply With Quote
  #3  
Old 03-01-2011, 08:55 AM
function12's Avatar
function12 function12 is offline
Senior User
 
Join Date: Jan 2002
Location: houston
Posts: 496
function12 is starting off with a positive reputation.
I would check the switch by the pedal.
__________________
See ya,
Eric
Reply With Quote
  #4  
Old 03-01-2011, 08:59 AM
Chuggster Chuggster is offline
Freshman User
 
Join Date: Sep 2010
Posts: 45
Chuggster is starting off with a positive reputation.
That's what I was hoping. I picked up 2 different brake switches this morning. What about the power tilt? It is stuck in the way up position.
Reply With Quote
Old 03-01-2011, 08:59 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2007, button, drive, expedition, ford, lever, lincoln, navigator, navugator, park, power, shift, steering, tilt, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 04:58 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup