Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-21-2011, 11:54 PM
Bluebronco85's Avatar
Bluebronco85 Bluebronco85 is offline
Senior User
 
Join Date: Sep 2008
Location: lakeland, Tn
Posts: 152
Bluebronco85 is starting off with a positive reputation.
Just got an 07 xlt

Been a member here on FTE but never posted anywhere but the 250 forum. Just bought an 07 XLT for the wife with 70k on the 5.4 I figured i should go on and replace the plugs asap. Jus looking for any tips/tricks to make this go as smooth as possible. Do these have as much trouble with the plugs as the older 5.4 and 4.6? Also was gonna change the tranny and rear diff. What trans and diff oils are recommended by factory/yall?
__________________
03' F250 7.3 FX4-6637,CCV mod,AIH delete,muffler delete,Petes cover,TC lock switch,Autometer gauges(boost, pyro, trans)hypertec max stage III,Trango tugger HD,Derale trans pan,3" lift and 35" Kelly M/T's, ORI pre runner w/8" helli lights. HID's. 119k
85' Bronco XLT
351W cam, carb, headers, 6" lift' 35" big horn MTs.
Reply With Quote
  #2  
Old 02-26-2011, 08:04 AM
fusionsp fusionsp is offline
New User
 
Join Date: Feb 2011
Posts: 16
fusionsp is starting off with a positive reputation.
Here is the link for the TSB I followed to remove my plugs.

http://www.phila.gov/fleet/Warranty%...-06%20FORD.pdf
Reply With Quote
  #3  
Old 03-04-2011, 02:09 PM
Cabinboy07 Cabinboy07 is offline
Freshman User
 
Join Date: May 2010
Posts: 29
Cabinboy07 is starting off with a positive reputation.
Just a warning on the plug replacement, I seem to remember topics here priviously about the tendency for the plugs to break while trying to remove them.
Reply With Quote
Old 03-04-2011, 02:09 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
07, xlt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup