Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 02-11-2011, 12:13 PM
doormansamaniego doormansamaniego is offline
New User
 
Join Date: Feb 2011
Posts: 11
doormansamaniego is starting off with a positive reputation.
2001 Expedition heater problems.

The heater in my Expedition does not blow any hot air.The AC works and I'm able to switch back and forth between panel, floor and defrost. Only cold air blows out. What is the problem and how can I fix it?
Reply With Quote
  #2 (permalink)  
Old 02-11-2011, 06:05 PM
madsonp's Avatar
madsonp madsonp is offline
Posting Guru
 
Join Date: Dec 2005
Location: Billings, Montana
Posts: 2,006
madsonp has a good reputation on FTE.madsonp has a good reputation on FTE.
First thing is to pull your temp control **** and see if it's broken, if that's not it, your blend door, or blend motor could be broken, if that's not it, your heater core could be plugged up.
__________________
2012 F-250 Lariat 6.2 L 4x4 (The Beast)
2013 Edge (Wife's)
76 E-350 Motorhome 460ci
42 Ford 9N Tractor (old pig)

Reply With Quote
  #3 (permalink)  
Old 02-11-2011, 06:47 PM
projectSHO89 projectSHO89 is offline
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 8,962
projectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to beholdprojectSHO89 is a splendid one to behold
See the FAQs in the HVAC section...
__________________
2001 F250 SD V10 4x4
HVAC FAQs: http://www.ford-trucks.com/forums/75...xpedition.html
Owner's manuals: www.motorcraftservice.com
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.” - Mark Twain
Reply With Quote
Old 02-11-2011, 06:47 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
1999, 2001, 99, ac, air, bloe, expedition, ford, heater, heating, hot, navigator, problems, switch, wont, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 07:59 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup