Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-26-2011, 08:33 AM
joiseystud joiseystud is offline
Junior User
 
Join Date: Jan 2011
Posts: 91
joiseystud is starting off with a positive reputation.
Power mirror memory

My mirrors are not moving to their position when I use the memory buttons on the seat. Any idea whay could be wrong?
Reply With Quote
  #2  
Old 12-29-2011, 05:16 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Red face Bringing back an old thread

Did you ever figure out what was wrong? My passenger side mirror isn't going back to where I set it. What's weird is it "usually" goes back to where my wife has hers saved. I can move it all around so I dont think it's the mirror itself. I was thinking its got to be the memory modue under the drivers seat that controls all the memory functions but was curious if anyone ran to this issue before.

Matt
Reply With Quote
  #3  
Old 12-30-2011, 02:11 AM
f150dave2002 f150dave2002 is offline
New User
 
Join Date: Jun 2010
Location: Aptos, Ca
Posts: 9
f150dave2002 is starting off with a positive reputation.
Not the same but after having the heated seat connector replaced I parked and went to get out and instead of going to the full back position, the seat went forward into the steering wheel... I was thinking a Christine type problem. I had to reach for the control button on the seat and the seat stopped going forward. Had to manually power the seat to the full back position. it's a 2007 Expy EB.

Time to disconnect the battery and see if the truck can re learn the seat memory and mirror positions...
Reply With Quote
  #4  
Old 01-09-2012, 04:14 PM
cstanley44's Avatar
cstanley44 cstanley44 is offline
Junior User
 
Join Date: Jun 2011
Location: Orlando, FL
Posts: 95
cstanley44 is gaining momentum as a positive member of FTE.
Note sure if you expect them to move when putting the key in the ignition but I believe the mirrors move when you unlock with the keyfob

Did you set the mirror position?
If memory serves me right, you need to put the seat and mirrors in your required arrangement, press the memory seat SET button, press the UNLOCK on the keyfob, then the memory seat NUMBER you want to save.
Reply With Quote
  #5  
Old 01-09-2012, 06:14 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Quote:
Originally Posted by cstanley44 View Post
Note sure if you expect them to move when putting the key in the ignition but I believe the mirrors move when you unlock with the keyfob

Did you set the mirror position?
If memory serves me right, you need to put the seat and mirrors in your required arrangement, press the memory seat SET button, press the UNLOCK on the keyfob, then the memory seat NUMBER you want to save.
I am setting exactly how the manual says to.
1. Adjust the seat, pedals and mirrors to desired position
2. Press the SET button.
3. Within 5 seconds of pressing the SET button press "1" ( or "2" in my case - my wife is #1 )

I can do this and everything is set. Then say I press the other preset for my wife, it goes to that seat and mirror position. But when I press my preset again everything goes back except the passenger mirror. It moves a little but not back where I had it. If I hit it again it might move a little bit more but not quite back to the correct spot. Doesnt matter if I use the remote or just press the button on the side of the seat.
The only thing that moves when I insert the key is the seat does the "Easy Enty" thing.

Matt
Reply With Quote
  #6  
Old 01-09-2012, 11:11 PM
Tylus's Avatar
Tylus Tylus is offline
MMNC (SS)
 
Join Date: Mar 2004
Location: Pearl Harbor
Posts: 10,541
Tylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputationTylus has a superb reputation
I have never gotten those presets to work properly

The Expy is possessed. Some days it'll work 100%...some days only the seat, or maybe the mirrors.

Completely random. It's probably user error, I just need to figure out what my issue is. I hate driving after the wife. She's 5'4" and I'm 6'3"...so you can imagine the seat/mirror changes
__________________
2002 Excursion XLT w/ V-10 <---Build thread
2015 Chevrolet Tahoe - I've owned 4 brand new Fords since 2006. Notice that I bought a Chevy this time. That should tell you something
Reply With Quote
  #7  
Old 01-10-2012, 05:18 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Quote:
Originally Posted by Tylus View Post
I hate driving after the wife. She's 5'4" and I'm 6'3"...so you can imagine the seat/mirror changes
I dont have to imagine, my wife is 5' and I'm 6' so its about the same difference.

I'm gonna have to bring the Expy to the dealer and have them replace the DSM module. According to everything I've read this thing controls all the memory functions so I think it's the likely culprit.

Matt
Reply With Quote
  #8  
Old 07-21-2012, 03:10 PM
raford raford is offline
New User
 
Join Date: Apr 2007
Location: West Palm Beach
Posts: 11
raford is starting off with a positive reputation.
I am having a similar problem, but I found a partial workaround. Try a couple repeated presses of the setting button. With my truck, when I shift from reverse to drive, the mirrors don't go back to my memory setting. What I do is, instead of shifting to drive I shift to park, take my foof off the brake, and hold down the number 1 memory button. The mirrors go back to the correct setting. Sometimes they go back in increments, so it makes me wonder if it is a binding or lubrication problem.
Reply With Quote
  #9  
Old 07-22-2012, 01:15 PM
evilwunn evilwunn is offline
Junior User
 
Join Date: Mar 2005
Location: Massachusetts
Posts: 50
evilwunn is starting off with a positive reputation.
I have the same problem but it's my drivers side mirror that acts up.
Reply With Quote
  #10  
Old 08-11-2012, 07:01 AM
repguns repguns is offline
Freshman User
 
Join Date: Mar 2010
Posts: 41
repguns is starting off with a positive reputation.
Same problem here, when I press my #, all memory functions work, except passenger mirror, it actually moves to the farthest point and then "clicks" 3 times against the stop. I have fixed this with a battery disconnect.
Reply With Quote
  #11  
Old 08-11-2012, 02:50 PM
raford raford is offline
New User
 
Join Date: Apr 2007
Location: West Palm Beach
Posts: 11
raford is starting off with a positive reputation.
Quote:
Originally Posted by repguns View Post
I have fixed this with a battery disconnect.
Would you please give more detail to "fixed it"????
Reply With Quote
  #12  
Old 08-11-2012, 05:02 PM
repguns repguns is offline
Freshman User
 
Join Date: Mar 2010
Posts: 41
repguns is starting off with a positive reputation.
Quote:
Originally Posted by raford View Post
Would you please give more detail to "fixed it"????
Had to replace the battery in the Expy. the disconnect fixed the problem so far.
Reply With Quote
  #13  
Old 08-19-2012, 10:36 PM
EcoBoostExpedition EcoBoostExpedition is offline
New User
 
Join Date: Aug 2012
Posts: 7
EcoBoostExpedition is starting off with a positive reputation.
More of the same.

I've been searching for a resolution to an issue with my mirrors and memory function in my 05 EB Expy for a few years now and I'm curious as to whether or not anyone has made any progress since the 11th.

Some history: I've gotten 3 new driver's seat tracks, 4 new driver's seat motors (newest one seems to be working...usually).

Now my driver's side mirror goes full up or full down when I press a preset. It will go full up or down, click around 3 times, then stay there. I readjust, press SET and my memory button, and it works for another couple of weeks. The 1 and 2 memory functions have been fully set since day 1 (in October 2004) and they get reset constantly because of the mirror, the seat, battery disconnects, ford technicians, whatever. Both key fobs are currently set as 1 or 2. I know it all usually works, and everything is set I just don't know why my mirror all of a sudden decided it needs more exercise.

Every now and then my easy exit seat will slide fully back and then can't decide how far away from the end of the seat rails it needs to be. It's a full back, forward a little, back a little, forward a little, back a little, forward a little, back a little, stop type of phenomenon. Really weird, started within a few weeks of the mirror too.

Usually this all happens when it's warmer out but the Expy has been chilling on the driveway since Oct of 04 (all 73,563.x miles) so it's not like it's new to heat and sunlight or anything. Plus I live in the Eastern Bay Area of CA so it never *really* gets hot here for more than like a month out of the year.

Anyway, maybe it's a shorted wire? The DSM logic board could be separating from itself from the heat after all these years?
It's pretty frustrating and my extended warranty is going to run out in about a year so a solid fix (which I know will never come) would be a great peace of mind for my wallet. Anyone with some ideas or info would be greatly appreciated! I'm heading up to my Ford service tomorrow to see if they can help me out at all or have any ideas.
Reply With Quote
  #14  
Old 08-20-2012, 02:51 PM
repguns repguns is offline
Freshman User
 
Join Date: Mar 2010
Posts: 41
repguns is starting off with a positive reputation.
Spoke too soon about the battery disconnect fix - it is now back to going full right for 10 clicks or so.
Reply With Quote
  #15  
Old 08-20-2012, 06:21 PM
EcoBoostExpedition EcoBoostExpedition is offline
New User
 
Join Date: Aug 2012
Posts: 7
EcoBoostExpedition is starting off with a positive reputation.
Alright so I just had the fastest trip to my Ford dealer I've ever had and this is what came from it:
2 (left and right) new mirror assemblies and the PCM module for the driver's seat/mirrors/pedal memory system.

Let me quickly explain the mirror assemblies, when you move the mirror in any direction using the interior switch, the mirror motor motion (say that 10x fast) is choppy and not smooth. The technician "advised me" to replace both since I still have warranty and they're both covered.

Now for the rest of it, when I arrived the service advisor heard my description and immediately thought it was the PCM that controls the memory function. His first advice was to disconnect the battery for 3 minutes or more, resetting all the computers in the car to factory default. I was fine with this but then I decided to let the technician take a look at it hoping they would trust me on my own diagnosis and just order parts under my Ford ESP. At first, the tech thought I was talking about the choppy motion in the mirror motor but then I described my actual issue to him in person and without any doubt he said "let's order you a new PCM module for the memory system" and I was quite happy about that since I knew that's what needed to be replaced.

Although the tech was unable to verify my issue, within minutes I hit unlock on my fob and the mirror went full tilt up. I grabbed the service advisor and he was able to verify that I needed a new PCM module for the memory function.

I'm not sure what the part number is, I'm sure it's not hard to find, but I should have a part number for both the mirror assemblies and the memory PCM in case anyone needs it.

I hope this actually fixes my problem!
Reply With Quote
Old 08-20-2012, 06:21 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
button, edge, expedition, f250, ford, freestyle, function, memory, mirror, mirroring, mirrors, power, seat, settings, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 PF/PT mirrors MC45 Super Duty & Heavy Duty 56 02-17-2014 07:24 PM
Mirror button, telescopic mirror and seat memory buttons suppose to light up? brkncly Super Duty & Heavy Duty 3 07-29-2012 12:29 PM
power mirror/memory seat controls grizzly6.0 6.7L Power Stroke Diesel 3 11-18-2010 08:19 PM
Swapping 2008+ telescoping mirrors, memory to no memory sdnomad Super Duty & Heavy Duty 1 10-11-2010 09:32 AM
2002 Excursion memory driver's seat. kamperco Excursion - King of SUVs 6 12-04-2005 08:07 PM



All times are GMT -5. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup