Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs
Sign in using an external account
Register Forgot Password?


Excursion - King of SUVs 2000 - 2005 Ford Excursion

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 01-19-2011, 03:10 PM
BroncoEx BroncoEx is offline
Senior User
 
Join Date: Mar 2007
Posts: 144
BroncoEx is starting off with a positive reputation.
Check Engine Light P2270

Hello all.

2005 v-10 x

Check engine light on... pulling a p2270 code

02 sensor Bank 1 / Sensor 2 signal stuck lean

Where exactly is this sensor on the exhaust?
__________________
08 F350 PSD CC King Ranch
pulling a 35' Holiday Rambler TT
2012 Fusion SEL
05 Explorer Eddie Bauer
96 Bronco Eddie Bauer
Reply With Quote
  #2 (permalink)  
Old 01-29-2011, 12:59 PM
icecold icecold is offline
Senior User
 
Join Date: Aug 2004
Posts: 103
icecold is starting off with a positive reputation.
the same thing is going on mine,haven't figured out what o2 it is.
did you get yours fixed?
thanks
pete
Reply With Quote
  #3 (permalink)  
Old 01-29-2011, 03:41 PM
BroncoEx BroncoEx is offline
Senior User
 
Join Date: Mar 2007
Posts: 144
BroncoEx is starting off with a positive reputation.
Yes, I did fix it. The 2005 V-10 has 3 Ox sensors. There is one on each side of the Y pipe coming off the engine, and the Bank 2 sensor 2 is on the exhaust right behind the Cat converter. It is on the top. Very easy to change.... I hit it with PB Blaster the night before..... then again about 1 hour before removing. You can buy a special socket to remove it, but I just unplugged it from the harness, cut the 4 wires off, and used a 7/8 in socket on a 1/2 drive to remove. Put the new on in with an open end wrench, plugged in harness, and was finished. It will take a couple of run - cooldown cycles for the Check engine light to go out. Purchased the sensor at Advance auto. $63 I believe. Very easy.

Good luck.
__________________
08 F350 PSD CC King Ranch
pulling a 35' Holiday Rambler TT
2012 Fusion SEL
05 Explorer Eddie Bauer
96 Bronco Eddie Bauer
Reply With Quote
Old 01-29-2011, 03:41 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs

Tags
10, 2007, 2270, 46, code, engine, explorer, f150, ford, ii, montego, obd, p0141, p2270, sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 03:28 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup