Go Back   Ford Truck Enthusiasts Forums > Diesel > Pre-Power Stroke Diesel (7.3L IDI & 6.9L)
Sign in using an external account
Register Forgot Password?


Pre-Power Stroke Diesel (7.3L IDI & 6.9L) Diesel Topics Only

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-07-2011, 09:19 AM
302grabber 302grabber is offline
New User
 
Join Date: Feb 2007
Posts: 15
302grabber is starting off with a positive reputation.
7.3 water pump problem

I was driving my 93 f-250 recently when the water pump shaft broke, dropping the fan into the shroud. What could have caused this, is it possible the pump locked up? What is involved in changing the water pump out, as in what else will have to be removed? Thanks in advance.
Reply With Quote
  #2  
Old 01-07-2011, 11:18 AM
PLC7.3 PLC7.3 is offline
Post Fiend
 
Join Date: Nov 2004
Location: Manitoba
Posts: 5,638
PLC7.3 is gaining momentum as a positive member of FTE.
Did the shaft break or the fan just unscrew from the pump.
__________________
93 F250 SC 4x4 E4OD 355LS
Reply With Quote
  #3  
Old 01-07-2011, 11:30 AM
Navasota Navasota is offline
New User
 
Join Date: Jan 2011
Posts: 7
Navasota is starting off with a positive reputation.
Eletrical Problems

Hello to all, I Need help with a 2000 Ford F250 Lariat cc 7.3 diesel. When it rains the horn starts blowing the heater comes on and the inside lights come on all without the key being in the switch, I took the batteries loose to stop all problems . It only do it when it rains, can anyone please tell me where to start?
Reply With Quote
  #4  
Old 01-07-2011, 11:55 AM
turbill's Avatar
turbill turbill is offline
Senior User
 
Join Date: Jun 2010
Location: Western Mass
Posts: 361
turbill is starting off with a positive reputation.
Quote:
Originally Posted by Navasota View Post
Hello to all, I Need help with a 2000 Ford F250 Lariat cc 7.3 diesel. When it rains the horn starts blowing the heater comes on and the inside lights come on all without the key being in the switch, I took the batteries loose to stop all problems . It only do it when it rains, can anyone please tell me where to start?
not a moderator but I'll say it anyways sorry if its not my place.

First wrong section your looking for the powerstroke section. I think two forums up for your year,
And second dont hyjack threads start a new one in the proper section.
hope you figure out your horn
and sorry 302grabber
__________________
1985 F-250 6.9 diesel,future plans, Turbo to 4" single stack, flatbed, dana 60 FAS, 5" lift w/ whatever tires end up fitting
Reply With Quote
  #5  
Old 01-07-2011, 12:02 PM
302grabber 302grabber is offline
New User
 
Join Date: Feb 2007
Posts: 15
302grabber is starting off with a positive reputation.
I believe the shaft has broke off.
Reply With Quote
  #6  
Old 01-07-2011, 12:07 PM
Navasota Navasota is offline
New User
 
Join Date: Jan 2011
Posts: 7
Navasota is starting off with a positive reputation.
I'm sorry Turbill, didn't mean to step on anyones toes. It's my first time trying to post but i will get it thanks.
Reply With Quote
  #7  
Old 01-07-2011, 12:19 PM
turbill's Avatar
turbill turbill is offline
Senior User
 
Join Date: Jun 2010
Location: Western Mass
Posts: 361
turbill is starting off with a positive reputation.
no problem nava just looking to help
__________________
1985 F-250 6.9 diesel,future plans, Turbo to 4" single stack, flatbed, dana 60 FAS, 5" lift w/ whatever tires end up fitting
Reply With Quote
  #8  
Old 01-07-2011, 06:34 PM
tecgod13 tecgod13 is offline
Posting Guru
 
Join Date: Sep 2007
Location: Western Mass
Posts: 2,313
tecgod13 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by 302grabber View Post
I believe the shaft has broke off.
If the shaft broke off, you have no choice but to replace it. As to why it would break, beats the hell out of me, unless it locked up real hard all of a sudden. Check to make sure its the pump shaft that actually broke, and not the fan clutch. I'm trying to remember what it looks like... but the fan clutch attaches to the water pump, and the fan attaches to the fan clutch (I think thats how it is). Another possibility is that one of the fan blades is broke or bent, and that threw the balance off and the vibration broke the shaft.

As far as replacing it, do a search, there are plenty of threads with good directions. One thing to note, watch out for the bolt lengths, depending on the water pump, some are shorter than others for the ones that penetrate the timing cover. If those are replaced with longer ones, they can contact the timing gears. The new pump will have directions, and I know there is a picture on here if you search for it.
__________________
1988 F250, 7.3L IDI, regular cab, long bed, 5spd ZF
Mods: ATS turbo, 3.5 inch exhaust, superduty springs front and rear, 4 gauge A-pillar pod: boost, pyro, coolant and 4th spot is switches; was 2wd, now 4wd with Dana 60 front axle
next projects: fix/complete the 3.5 inch exhaust (tailpipe exits waaaaaay to low, and needs to be extended out from under the bed) swap to a rust free cab
Reply With Quote
  #9  
Old 01-07-2011, 07:24 PM
frodfreak's Avatar
frodfreak frodfreak is offline
Senior User
 
Join Date: Dec 2010
Posts: 118
frodfreak is starting off with a positive reputation.
is there anything wrong wit the rad. or fan? were u leaking coolant before? if so the pump houseing was most likly cracked this happened on my 5.0
Reply With Quote
  #10  
Old 02-04-2011, 12:04 PM
Navasota Navasota is offline
New User
 
Join Date: Jan 2011
Posts: 7
Navasota is starting off with a positive reputation.
Steering Problems

Navasota- Hello to all, I Need help with a 2000 Ford F250 Lariat cc 7.3 diesel. I had all new ball joints put on and now the truck has a lot of play in the steering, it is hard to keep it in the lane when driving are if i hit a bump. what else could this be? my wife is scared to drive with this happening. If you have any imformation it will be greatly appreciated,Thanks
Reply With Quote
  #11  
Old 02-04-2011, 12:19 PM
Festus Hagen's Avatar
Festus Hagen Festus Hagen is offline
Methanoholic
 
Join Date: Mar 2009
Location: Maine (NorCal Native)
Posts: 5,124
Festus Hagen has a very good reputation on FTE.Festus Hagen has a very good reputation on FTE.Festus Hagen has a very good reputation on FTE.Festus Hagen has a very good reputation on FTE.
Navasota,

You will get much more help in the correct forum for your truck, this forum is for the PRE POWERSTROKE diesels. i.e. pre 1994.5 ...

You want these two forums: 1999 - 2003 7.3L Power Stroke Diesel or Super Duty & Heavy Duty

-Enjoy
fh : )_~
__________________
-= Improve Knowledge ... Share your's! =-
WANTED: Factory Turbo Wastegate Housing.
1994 F350 XLT CrewCab Dually IDIT ZF5 4.10's
1986 F250 SuperCab Dually 4WD 7.3IDI T19 BW1345 D50/60TTB Sterling 10.25 3.55's
1991 F250 StandardCab 2WD NO-IDI NO-ZF5 Sterling 10.25 NO-4.10's - Gone to the Toyota factory!
Reply With Quote
Old 02-04-2011, 12:19 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
T444E water pump A/Ox4 1999 - 2003 7.3L Power Stroke Diesel 140 09-05-2014 03:57 PM
Coolant Leak Issue xtmsports Expedition & Navigator 9 01-12-2010 09:28 PM
Water Pump Polkster 1999 - 2003 7.3L Power Stroke Diesel 14 03-12-2009 05:39 PM
Water Pump dell 1994.5 - 1997 7.3L Power Stroke Diesel 12 02-20-2006 09:01 AM
water pump rotation dmc919 Small Block V8 (221, 260, 289, 5.0/302, 5.8/351W) 6 05-12-2004 07:48 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > Pre-Power Stroke Diesel (7.3L IDI & 6.9L)

Tags
1999, 2000, 73, clutch, diesel, f250, fan, ford, locked, powerstroke, problem, pump, replacing, water, waterpump

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 03:42 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup