Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-04-2010, 01:24 AM
Pro Form Pro Form is offline
New User
 
Join Date: Dec 2010
Posts: 2
Pro Form is starting off with a positive reputation.
No Power, No Turbo boost Under 2G RPM

2006 F-250 6.0. 4" exhaust straight from turbo, Sinister Delete kit, Banks Intake, Edge Tuner.

First noticed exhaust louder, more throaty (similar to gas dual piped V8) upon start, after 1-3 minutes, turbo kicked in and whistled like previous. Problem continued with minor inconvenience (should have known to look into this). This week, started truck in cold (live in MN) and loud hard idle never stopped. No power under 2G RPM and no turbo boost until +2G RPM, Then turbo boosts and drives, runs like normal. Low idle truck is loud and sounds like gas piped V8. Thinking I might have a turbo that is only working in once or two stages. Thoughts? Thanks.
Reply With Quote
  #2  
Old 12-04-2010, 06:34 AM
nfntruth nfntruth is offline
Senior User
 
Join Date: Apr 2003
Location: Charleston
Posts: 201
nfntruth is starting off with a positive reputation.
Wow, that sucks man. I was thinking I had problems, I was having the opposite. I was getting up to 10lbs of boost at 1500 RPMs while eggshell driving. Dealer said the vanes were sticking and told me to add some cetane booster and 'get on it' everyday until it stops smoking. Worked like a charm.

But you say yours works fine over 2000rpms? Could be a software problem, if the programming that controls the geometry of the vanes in the turbo is screwed up for <2k rpms....and I notice you have some mods that tinker with factory settings. Could be a problem there. Try flashing back to stock and see what happens.
__________________
06 F250, Lariat 6.0L Powerstroke, Draw tite hide a hitch gooseneck
2001 Isuzu Vehicross, Aussie Locker, 34" Kevlar tires, tons of extras, 1 of about 4000 ever made
1993 Trooper RS, Aussie Locker, 33" Mudders, 1 of 1500 in the US
http://www.fuelly.com/sig-us/55407.png
Reply With Quote
  #3  
Old 12-04-2010, 06:41 AM
cliles55's Avatar
cliles55 cliles55 is offline
Senior User
 
Join Date: Mar 2005
Location: TX
Posts: 173
cliles55 is starting off with a positive reputation.
I was talking to a guy yesterday at the Ford house and discussed a turbo problem he had with his. Whichever model it was, the turbo had variable vanes; lost power and turbo was whining. The dealership found corrosion in the area of the variable vanes; split the turbo, cleaned it out and sent him on his way. He mentioned it was the "dirty side"; perhaps the exhaust side inlet to the turbo.

Hope this helps and that you are still in warranty,
Curt
__________________
Curt
2008 F250 XL 4X4 5.4L
Owner of a Lisle 65600
Reply With Quote
  #4  
Old 12-04-2010, 09:30 AM
carltonwebb's Avatar
carltonwebb carltonwebb is offline
Posting Guru
 
Join Date: Oct 2010
Posts: 1,645
carltonwebb has a very good reputation on FTE.carltonwebb has a very good reputation on FTE.carltonwebb has a very good reputation on FTE.carltonwebb has a very good reputation on FTE.
When it does it under 2k rpm, does it roll out the black smoke and then get t driving normal?
__________________
2000 Ford F-250 Supercab, 7.3 PSD, Auto, Bone Stock, 202,400k. 08 SD tailgate.
2011 Ford Escape Limited, V-6, For the wife.

Reply With Quote
  #5  
Old 12-04-2010, 12:06 PM
nfntruth nfntruth is offline
Senior User
 
Join Date: Apr 2003
Location: Charleston
Posts: 201
nfntruth is starting off with a positive reputation.
Quote:
Originally Posted by cliles55 View Post
I was talking to a guy yesterday at the Ford house and discussed a turbo problem he had with his. Whichever model it was, the turbo had variable vanes; lost power and turbo was whining. The dealership found corrosion in the area of the variable vanes; split the turbo, cleaned it out and sent him on his way. He mentioned it was the "dirty side"; perhaps the exhaust side inlet to the turbo.

Hope this helps and that you are still in warranty,
Curt
My dealership told me cleaning the turbo was not covered by warranty?
__________________
06 F250, Lariat 6.0L Powerstroke, Draw tite hide a hitch gooseneck
2001 Isuzu Vehicross, Aussie Locker, 34" Kevlar tires, tons of extras, 1 of about 4000 ever made
1993 Trooper RS, Aussie Locker, 33" Mudders, 1 of 1500 in the US
http://www.fuelly.com/sig-us/55407.png
Reply With Quote
  #6  
Old 12-04-2010, 12:33 PM
cliles55's Avatar
cliles55 cliles55 is offline
Senior User
 
Join Date: Mar 2005
Location: TX
Posts: 173
cliles55 is starting off with a positive reputation.
Quote:
Originally Posted by nfntruth View Post
My dealership told me cleaning the turbo was not covered by warranty?
He bought the truck in Central Texas and was enroute to CO; truck was acting up in Albequerque, NM. The dealership there hooked him up; he paid warranty $100 deductible (but received a check back from Ford afterwards). I'd call that good customer treatment, warranty or not. I want to say he mentioned "emissions", perhaps that was the difference.

I'd say they deserved their 72-bay service department with service like that!
__________________
Curt
2008 F250 XL 4X4 5.4L
Owner of a Lisle 65600
Reply With Quote
  #7  
Old 12-04-2010, 03:15 PM
lakewood's Avatar
lakewood lakewood is offline
Posting Guru
 
Join Date: Oct 2009
Location: Bradenton, FL
Posts: 1,318
lakewood is gaining momentum as a positive member of FTE.
This just happend on my 05, except i didnt see boost till 3k rpms, and at 3k i would only get 5psi. Try getting the turbo cleaned, and the unison ring checked. if cleaning returns the truck to normal you should be fine. But if after being cleaned it loses boost again, its time for a new turbo. This is what happened to my truck, had turbo cleaned, it gummed up again and a new turbo was needed. Good luck
__________________

2005 F-250 CCSB FX4 Lariat PSD
2001 F-350 CCLB XL SRW PSD
I'm a Rev-X dealer. PM me for forum member deals!
Reply With Quote
  #8  
Old 12-06-2010, 02:59 PM
SoCalSuperDuty03's Avatar
SoCalSuperDuty03 SoCalSuperDuty03 is offline
Elder User
 
Join Date: Jul 2003
Location: SoCali!!
Posts: 979
SoCalSuperDuty03 is gaining momentum as a positive member of FTE.SoCalSuperDuty03 is gaining momentum as a positive member of FTE.
ProForm... I am not sure if the '06's have an Exhaust Back Pressure sensor in the loop, but if they do, check it. I have had three trucks with the EBP's go bad, and the symptoms are EXACTLY what you are saying.

Upon startup, no turbo whistle (sometimes not until you drive down the street), no boost below 2000 RPM, then runs hard like it should.

My personal truck did this and I couldn't figure it out (all VGT tests performed) until I hooked a Vehicle Data Recorder to it and took it on a couple hundred mile drive.

In addition, even after my personal truck was warm during long drives, if I was off the throttle descending a hill, and then stood in the throttle to accelerate, my truck would lay down for 4-5 seconds, suddenly build boost and run normal. This would not occur each time, but the cold start/no boost problem definitely did.

The other two trucks came to me after they were told both needed turbocharger cleaning or replacement. Neither did. Obviously some trucks need turbos, but spending $1500-2000 when that actually wasn't the problem would suck!
__________________
05/12, '03, 05/07 6.0, Torqshift, CC, SB, 4WD, FX4 Sport, Sonic Blue/Grey, 8" Edge lift, six Foxes, Fox damper, 38x15.50x18 Toyo M/T's, Weld Renegades, Detroit Locker, 4.30's, Mag-Hytecs, ARP's, Hypermax HG's, Fluidamper, Spearco IC, MBRP 304, Trans; Converter and SCT tuning by John Wood, Custom Trac Bars, Onboard Air, AMP steps.... lots more
Reply With Quote
Old 12-06-2010, 02:59 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Tags
2000, 2004, 60, boost, booste, booster, f150, f250, ford, power, rpm, truck, trucks, turbo, turboboost

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No turbo at idle Andrews6.0 Super Duty & Heavy Duty 2 01-30-2014 08:52 AM
horribly running after go-go intake manifold and turbo clean surfaccing 6.0L Power Stroke Diesel 7 04-08-2013 01:55 PM
Just rebuilt, put in arp studs, gaskets, the works - now no boost at all from turbo. superv10 6.0L Power Stroke Diesel 2 05-10-2012 11:18 PM
Loud whoosh under hood. ROBBINthaHOOD 6.0L Power Stroke Diesel 11 11-22-2011 10:55 AM
What does my truck got? fordman14 Performance & General Engine Building 1 04-17-2003 10:12 PM



All times are GMT -5. The time now is 02:27 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup