engine idle drops - Ford Truck Enthusiasts Forums



engine idle drops

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-02-2010, 08:07 PM
jeremy2008's Avatar
jeremy2008 jeremy2008 is offline
Senior User
Thread Starter
 
Join Date: May 2009
Location: Albany OR
Posts: 387
jeremy2008 is starting off with a positive reputation.
engine idle drops

So what would cause a efi 460 to drop idle speed an act like it is going to die when driving the engine just got rebuilt i have 600 miles on it i am going to do a oil change soon. I was thinking injectors run cleaner threw them maybe there o rings? Can anyone think of anything els that would make it do this.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Duraspark II question Rusty_S Electrical Systems/Wiring 2 08-01-2013 10:07 PM
Return to idle issue flainn Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 6 07-11-2011 07:30 PM
bad idle ssquints999 1987 - 1996 F150 & Larger F-Series Trucks 3 01-23-2009 04:26 PM
98 Expedition Rough/Low Idle rwallin 1997-2006 Expedition & Navigator 2 08-04-2004 10:06 AM
engine braking shunshine X Excursion - King of SUVs 3 03-24-2003 09:30 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:01 AM.