Go Back   Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


1994.5 - 1997 7.3L Power Stroke Diesel SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-08-2010, 12:05 AM
dougbrown's Avatar
dougbrown dougbrown is offline
Postmaster
 
Join Date: Nov 2009
Location: Crapy southern New Jersey
Posts: 4,543
dougbrown has a very good reputation on FTE.dougbrown has a very good reputation on FTE.dougbrown has a very good reputation on FTE.
Battery light on dash off then on then off! Help

So I have a 96 F250, 136,030.6 miles on it, XL. I just did a oil change today that how I know it so well. I was having a problem with my battery light coming on the off a few months ago. I couldn't figure the problem out then, checked the altonter, batteries, cables. When I load test the batterys they where low. So I knew replacing them was soon but at the time money was not there. I replace them about 1.5 months ago when they quit on me. That stoped my battery light on dash problem. It when away after that! So I just figured it was batterys. Well today it was back on and now on when the truck is running. I know the start is going bad and cranks slow. Battery load test good! Figured the old batterys killed the starter. So I picked up a new one and it going in tomorrow along with a new start relay. Old one looks stock and for 22 bucks It can get a new one. I tryed to test the altonator to see how many volts it putting out but my voltage meter meet the fan blades before I could test it.

What could be causing the light to come on? Anything I should check while working on it? Any help would be great! I will get a new volt meter tomorrow. Also would that throw a code the code reader at work will pick up?
__________________
Doug
96 F250XL Psd 4x4 180,000, afe intake, 3" DP, Isspro gauges, D60 swap, Chip, next Stage 1's
00 F250xlt,psd, 2wd, 3:73, 398,000 , K&N intake, super chip, auto! (Dad's)
97 F Super Duty 7.3L,ZF5,166xxx, Dump,
01 F250 CCSB 7.3L stock for now, Boss truck
Reply With Quote
  #2  
Old 11-08-2010, 08:36 AM
tbone heller's Avatar
tbone heller tbone heller is offline
Senior User
 
Join Date: May 2009
Location: Canton, Georgia
Posts: 159
tbone heller is starting off with a positive reputation.
Sounds like the alternator has a bad diode in it. Replace the alternator.
__________________
1997 F-Super Duty XLT, PSD, 5-Speed, 6637, 3" downpipe, 4" exhaust
Reply With Quote
  #3  
Old 11-08-2010, 09:38 AM
Cuda_jim's Avatar
Cuda_jim Cuda_jim is offline
Post Fiend
 
Join Date: Oct 2003
Location: MICHIGAN
Posts: 5,903
Cuda_jim has a great reputation on FTE.Cuda_jim has a great reputation on FTE.Cuda_jim has a great reputation on FTE.Cuda_jim has a great reputation on FTE.Cuda_jim has a great reputation on FTE.
Check the connector on the top of the alternator. The socket and pins are known to get loose. The wires almost always get flattened from laying on them while working in the engine bay.
__________________
JIM
Reply With Quote
  #4  
Old 11-08-2010, 10:51 AM
ccarrier's Avatar
ccarrier ccarrier is offline
Elder User
 
Join Date: Feb 2010
Location: johnson city tn
Posts: 842
ccarrier has a good reputation on FTE.ccarrier has a good reputation on FTE.
There is a rubber hose that lays across the plugs on the ALT that causes this problem. Bend the metal loop bracket it's in back so it doesnt lay on it. The hose vibrates the plugs and causes the light. Well it did on mine anyway
__________________
1997 f250 supercab shortbed 7.3 PSD 5 speed 4x4, stage 2 afe intake ,4 inch MBRP , 3 inch MBRP down pipe, intercooled,full force stage 1 injectors
some gauges,valair clutch kit w/ single mass flywheel,termy modded 17*,dp tuner f5, BDS front add a leaf ,08 rear diff cover,skyjacker shocks
Reply With Quote
  #5  
Old 11-08-2010, 03:17 PM
Brown Falcon's Avatar
Brown Falcon Brown Falcon is offline
Post Fiend
 
Join Date: Jul 2008
Location: Corvallis,OR
Posts: 7,484
Brown Falcon is a name known to allBrown Falcon is a name known to allBrown Falcon is a name known to allBrown Falcon is a name known to allBrown Falcon is a name known to allBrown Falcon is a name known to all
Check the main wire on the back of the alternator. The ring connector on my broke a few months ago and needed to be replaced. It was still charge when it was touching but it was barely held on by the little rubber boot.
__________________
Evan Once a Marine Always a Marine Oregon Chapter Member
'06 F150 SCab 4x4 XLT 5.4
'10 Escape 3.0 V6, 4x4
'95 F350 CC 4x4 Powerstroke - GONE but not forgotten
Reply With Quote
  #6  
Old 11-08-2010, 11:17 PM
oldbird1965's Avatar
oldbird1965 oldbird1965 is online now
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 13,105
oldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to all
Mine is starting the flashing battery light again as it has twice in the past. Both times I replaced the alternator and it fixed it. Now I need another one, Advance Auto is going to get tired of me getting a free replacement all the time. When I pull my camper I use a invertor to run two small refrigerators while driving down the road. My alternator really gets a work out and that is the reason they keep wearing out. If I replace the alternator again and the light keeps flashing well then, I might have one of the problems listed above.
__________________
Glenn The Mule-96 2WD F250 EC/LB auto PSD
The Mare 97 dually cc,modified s366 turbo,stage II's,IC,studs,springs,rods,JW auto,4:10 LS,air bags,SD uvch,efuel,FS2500 bypass oil filter,HVHF IDM,IH WP,6.0 trans cooler & rad fan,MBRP 4",SD tensioner,AFE air filter,220 amp alt,38 gal rear tank & 33 gal aux bed tank,aux oil cooler,soundproofed,3 different TS chips,ac cold mod,XS batteries,riffraff hpop reservoir,aluminum radiator,HoneyBadgerJr hpop, water injection
Reply With Quote
  #7  
Old 11-09-2010, 12:03 PM
dougbrown's Avatar
dougbrown dougbrown is offline
Postmaster
 
Join Date: Nov 2009
Location: Crapy southern New Jersey
Posts: 4,543
dougbrown has a very good reputation on FTE.dougbrown has a very good reputation on FTE.dougbrown has a very good reputation on FTE.
I dove around 50 miles yesturday and had no problem with it. Restarted fine, so i'm thinking it the problem described up top. Will check in a little.
__________________
Doug
96 F250XL Psd 4x4 180,000, afe intake, 3" DP, Isspro gauges, D60 swap, Chip, next Stage 1's
00 F250xlt,psd, 2wd, 3:73, 398,000 , K&N intake, super chip, auto! (Dad's)
97 F Super Duty 7.3L,ZF5,166xxx, Dump,
01 F250 CCSB 7.3L stock for now, Boss truck
Reply With Quote
  #8  
Old 11-12-2010, 08:38 PM
MissIndependent's Avatar
MissIndependent MissIndependent is offline
Posting Guru
 
Join Date: Jul 2008
Location: Blackwater, VA
Posts: 1,151
MissIndependent is gaining momentum as a positive member of FTE.MissIndependent is gaining momentum as a positive member of FTE.
my truck has a similar battery light issue- it was intermittent for a while and now steady since the colder weather has set in (she likes it about as well as i do). new batteries, starter, and fender solenoid within the past several months, and alternator tests good. my boyfriend, a certified tech, was wondering about a voltage regulator??

i need top off power steering fluid and change a light bulb tomorrow, so i guess i'll add checking above-mentioned alternator items to the list lol...she starts strong and runs fine, so i'm not too worried, it's just annoying to see the light
__________________
"she's not crazy, just a little misunderstood"

1996 F250 XLT 7.3L PSD SC/LB 4x4, auto, 4.10s, 4" suspension lift on 37" Goodyear Wrangler MTs, 6637 air filter, 208k+ mi and counting

Plotting: stacks, gauges, tw chip, cat/muffler delete, and more that won't fit
Reply With Quote
  #9  
Old 11-12-2010, 08:58 PM
blue66tang95f150 blue66tang95f150 is offline
Elder User
 
Join Date: Apr 2003
Posts: 621
blue66tang95f150 is starting off with a positive reputation.
Don't forget it could be the regulator. Mine was flashing intermittently for a while. I replaced the regulator and it has been fine ever since. I noticed when the light came on, the voltage gauge would jump slightly, I also noticed the batteries were boiling over.
__________________
95 F250 7.3 5speed 4x4 (DD)
04 EB Expedition 4x4 (Wife's rig)
66 Mustang 332 Stroker
86 CJ7 Current Project
Reply With Quote
  #10  
Old 11-12-2010, 09:30 PM
Action4478's Avatar
Action4478 Action4478 is offline
<- (Madvan)'s Avatar
 
Join Date: Aug 2006
Location: Muskegon Mi
Posts: 9,989
Action4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputation
The battery light is always the alternator , or the connector on top of it ...The regulator is in the alternator ....
__________________
Rick.......
"Most stuff's just stuck & needs hittin with a hammer".... Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
Special thanks to RacerX USA
'Life may not be the party we hoped for... but while we are here we might as well dance!'
Reply With Quote
  #11  
Old 11-12-2010, 09:58 PM
blue66tang95f150 blue66tang95f150 is offline
Elder User
 
Join Date: Apr 2003
Posts: 621
blue66tang95f150 is starting off with a positive reputation.
Quote:
Originally Posted by Action4478 View Post
The battery light is always the alternator , or the connector on top of it ...The regulator is in the alternator ....
The regulator is on the back of the alternator and it can be replaced separately. It was making my light come ON on the dash when it would randomly quit working.
__________________
95 F250 7.3 5speed 4x4 (DD)
04 EB Expedition 4x4 (Wife's rig)
66 Mustang 332 Stroker
86 CJ7 Current Project
Reply With Quote
  #12  
Old 11-12-2010, 10:03 PM
Action4478's Avatar
Action4478 Action4478 is offline
<- (Madvan)'s Avatar
 
Join Date: Aug 2006
Location: Muskegon Mi
Posts: 9,989
Action4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputation
Quote:
Originally Posted by blue66tang95f150 View Post
The regulator is on the back of the alternator and it can be replaced separately.
Cool ...

How do you test which one is the problem ?

The light on , it is still the alternator , whether it is the alternator windings , or the regulator ....
That was my point ....
__________________
Rick.......
"Most stuff's just stuck & needs hittin with a hammer".... Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
Special thanks to RacerX USA
'Life may not be the party we hoped for... but while we are here we might as well dance!'
Reply With Quote
  #13  
Old 11-13-2010, 12:27 AM
oldbird1965's Avatar
oldbird1965 oldbird1965 is online now
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 13,105
oldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to alloldbird1965 is a name known to all
Mine is doing it as I said but I thought I would throw in that I put my scan guage on volts and I'm always showing 14 +or-??
__________________
Glenn The Mule-96 2WD F250 EC/LB auto PSD
The Mare 97 dually cc,modified s366 turbo,stage II's,IC,studs,springs,rods,JW auto,4:10 LS,air bags,SD uvch,efuel,FS2500 bypass oil filter,HVHF IDM,IH WP,6.0 trans cooler & rad fan,MBRP 4",SD tensioner,AFE air filter,220 amp alt,38 gal rear tank & 33 gal aux bed tank,aux oil cooler,soundproofed,3 different TS chips,ac cold mod,XS batteries,riffraff hpop reservoir,aluminum radiator,HoneyBadgerJr hpop, water injection
Reply With Quote
  #14  
Old 11-13-2010, 04:17 PM
Action4478's Avatar
Action4478 Action4478 is offline
<- (Madvan)'s Avatar
 
Join Date: Aug 2006
Location: Muskegon Mi
Posts: 9,989
Action4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputationAction4478 has a superb reputation
Glenn ,did you check the connector?..
__________________
Rick.......
"Most stuff's just stuck & needs hittin with a hammer".... Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
Special thanks to RacerX USA
'Life may not be the party we hoped for... but while we are here we might as well dance!'
Reply With Quote
  #15  
Old 11-13-2010, 08:23 PM
Ken_C's Avatar
Ken_C Ken_C is offline
Elder User
 
Join Date: Aug 2009
Location: Michigan
Posts: 865
Ken_C is gaining momentum as a positive member of FTE.
Ken Cabanaw
Voltage regulator wether internal or external to the alternator is replaceable. Its all in how much work do you want to do.
__________________
1997 Ford F-250HD CC SB Auto 4X4 3.55s 7.3 PSD Rif-Raf 6637, Stancor GPR, MBRP 3" DP to Stainless 4" straight exhaust. 95,000 original miles and counting.
Michigan Chapter
Reply With Quote
Old 11-13-2010, 08:23 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Passenger battery not charging. 99 7.3 bigbadbob17 1999 - 2003 7.3L Power Stroke Diesel 17 12-16-2014 08:25 AM
2003 7.3.....Alternator problems rwtdct 1999 - 2003 7.3L Power Stroke Diesel 14 08-07-2012 09:05 PM
BATTERY LIGHT ON&OFF BLADE35 6.0L Power Stroke Diesel 6 09-22-2010 01:50 AM
Battery Light mediaman67 Aerostar 37 03-18-2010 05:42 PM
voltage regulator blues punchy1 Electrical Systems/Wiring 11 11-30-2003 05:19 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel

Tags
96, 97, altenator, batery, battery, coming, escape, f150, f250, ford, light, muskegon, on, powerstroke, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup