Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-17-2010, 09:16 PM
Misky6.0's Avatar
Misky6.0 Misky6.0 is online now
Postmaster
 
Join Date: Oct 2010
Location: Within Sight of Orlando
Posts: 3,539
Misky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputation
Ultra-gauge on 2005 Ex 6.0, trouble reading ODBII

My new ultra-gauge stops reading a number of sensors once I start
the engine. Even with the latest FW with a new mod for the 6.0
they are still having issues reported. I've worked with their support to
try to resolve my issue, but they are gettting other reports as well
from F250/F350 6.0 owners.

I'm going to return the unit for a refund, but was wondering if
anyone has had any problems with other electronic ODBII readers in
the '05 6.0 (Ex, F250, F350) models.

No need to go buy an Insight CTS if it'll have issues ready the
sensors too.
Reply With Quote
  #2  
Old 10-18-2010, 09:11 AM
BPofMD's Avatar
BPofMD BPofMD is offline
Posting Legend
 
Join Date: Jul 2005
Location: Millersville, MD
Posts: 31,538
BPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputationBPofMD has a superb reputation
Most all 6.0 owners of the UltraGauge are having the same problems. They have issued a recall from most all Ford diesel owners to update the units. Mine will go in the end of the month when my towing season is over. I use the UG mainly for the ECT readout.
__________________
BPofMD - Bud - USN-Actively Retired
2005 F250 PSD 4X4 LB Crew-cab Arizona Beige / Blue Spring / Gauges / Coolant Filter / SG-II / Peragon Bed Cover/ P/S Filter/ MAG-HYTEC differential cover/

2007 Arctic Fox 30' Fifth Wheel
2012 VW Passat SE TDI - SG-II (An ALL-DIESEL family)
Reply With Quote
  #3  
Old 10-18-2010, 09:52 AM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,578
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
I'm thinking that that is specific to the unit that you have. I haven't heard of issues like that with others that read through the OBD-II port. Of course, I would need to know what sensors you are talking about as they may be sensors that I'm not using for my digital readout either.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
  #4  
Old 10-18-2010, 10:01 AM
Misky6.0's Avatar
Misky6.0 Misky6.0 is online now
Postmaster
 
Join Date: Oct 2010
Location: Within Sight of Orlando
Posts: 3,539
Misky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputation
If I leave the key in the "run" position (w/o actually starting the engine) the same sets of sensors stop reporting after about 10 seconds.

* fuel level (and thus all the MPG related gauges)
* intake air temp
* intake air pressure ABS
* MAP sensor
* EGR % error

I'm pretty sure it's a problem with the UG firmware, vs. my ODBII.
I just wanted to here from someone that these things work using
something else before I go and buy another gauge setup.
__________________
'05 EB Excursion 2wd 6.0 3.73/LS Mich LTX M/S2, Diesel Kleen (gray bottle), FICM w/atlas40 from Ed, RAS, Read Head Steering, scangaugeII w/Blendmount, '08+ Tow Mirrors, Magnefine PS filter, SPAtechnique Dual-Gauge (FP & Volt), Blue Spring, Air Lift 1000, Interior Dome Override, DieselSite Coolant Filter, BPD Oil & EGR coolers, Rancho RS9000, Hellwig, Diehard Platinum x2
Reply With Quote
  #5  
Old 10-18-2010, 10:04 AM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,578
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
Quote:
Originally Posted by Misky6.0 View Post
If I leave the key in the "run" position (w/o actually starting the engine) the same sets of sensors stop reporting after about 10 seconds.

* fuel level (and thus all the MPG related gauges)
* intake air temp
* intake air pressure ABS
* MAP sensor
* EGR % error

I'm pretty sure it's a problem with the UG firmware, vs. my ODBII.
I just wanted to here from someone that these things work using
something else before I go and buy another gauge setup.


I don't use EGR% error or Intake ABS sensor, so I can't say one way or the other on those.

I use Fuel Level % all the time on the DashDAQ without issue. I haven't used the last two in the longest time though.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
  #6  
Old 10-18-2010, 10:25 AM
Misky6.0's Avatar
Misky6.0 Misky6.0 is online now
Postmaster
 
Join Date: Oct 2010
Location: Within Sight of Orlando
Posts: 3,539
Misky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputation
Quote:
Originally Posted by BPofMD View Post
Most all 6.0 owners of the UltraGauge are having the same problems. They have issued a recall from most all Ford diesel owners to update the units. Mine will go in the end of the month when my towing season is over. I use the UG mainly for the ECT readout.
I couldn't find any postings on FTE about any problems related to UG.
The UG website indicated the latest FW fixed the MPG related sensors.
They have since added the 6.0 to the compatibility issue list.

UG Support was pretty forthcoming about lots of complaints re the issues with 6.0, so I'll be able to get my $$$ back and have to pick out an insight model now. I like the new units with up to 8 readings on the page.
Plus support of external sensor(s) ie: Fuel Pressure (someday?)
__________________
'05 EB Excursion 2wd 6.0 3.73/LS Mich LTX M/S2, Diesel Kleen (gray bottle), FICM w/atlas40 from Ed, RAS, Read Head Steering, scangaugeII w/Blendmount, '08+ Tow Mirrors, Magnefine PS filter, SPAtechnique Dual-Gauge (FP & Volt), Blue Spring, Air Lift 1000, Interior Dome Override, DieselSite Coolant Filter, BPD Oil & EGR coolers, Rancho RS9000, Hellwig, Diehard Platinum x2
Reply With Quote
  #7  
Old 10-18-2010, 11:04 AM
tex25025's Avatar
tex25025 tex25025 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Plano TX and Brentwood TN
Posts: 10,578
tex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud oftex25025 has much to be proud of
Quote:
Originally Posted by Misky6.0 View Post
Plus support of external sensor(s) ie: Fuel Pressure (someday?)
That should be forthcoming by the end of the year or early next year.

I do know the dashdaq already supports external sensors though.
__________________
2014 6.7 PSD King Ranch F350 SRW
Reply With Quote
  #8  
Old 10-18-2010, 06:37 PM
amgpro2 amgpro2 is offline
Senior User
 
Join Date: Jul 2007
Location: central valley, CA
Posts: 233
amgpro2 is starting off with a positive reputation.
From UG support site:

MPG Sensor Error

Description:
Many or all of the various MPG gauges display "Err" or nonsensical values. Other gauges such as RPM, MPH, Engine Temp, display correctly. This is a common issue on Ford F250 and F350 Diesels.

FIX:

If your UltraGauge version, MENU--> UltraGauge Setup --> Version, is 9/14/10 or later,
please set the "Force MPG sensor" to "MAP".
This is set at: MENU --> Vehicle Setup --> Force MPG sensor.

If your UltraGauge version is prior to 9/14/10, please create a support ticket.
Reply With Quote
  #9  
Old 10-18-2010, 07:00 PM
Bones3 Bones3 is offline
New User
 
Join Date: Apr 2007
Posts: 12
Bones3 is starting off with a positive reputation.
I have had the same problem. I sent it back to ultra-gauge for the update. When I got it back, same problem as Misky6.0. I'm going to try to send mine back for a refund.
Reply With Quote
  #10  
Old 10-18-2010, 08:19 PM
Misky6.0's Avatar
Misky6.0 Misky6.0 is online now
Postmaster
 
Join Date: Oct 2010
Location: Within Sight of Orlando
Posts: 3,539
Misky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputationMisky6.0 has a superb reputation
Quote:
Originally Posted by amgpro2 View Post
From UG support site:

FIX:

If your UltraGauge version, MENU--> UltraGauge Setup --> Version, is 9/14/10 or later,
please set the "Force MPG sensor" to "MAP".
This is set at: MENU --> Vehicle Setup --> Force MPG sensor.

If your UltraGauge version is prior to 9/14/10, please create a support ticket.
Yes, that is what it says. I just bought a unit with the latest FW
(with the "Force MPG sensor") and did the above setup and it didn't
work. Interestingly, it's "more" than just MPG calculations.
My "intake air temp", "intake Manifold ABS PSI", and "fuel level"
also stop reading after about 10 seconds (with key in the run, but
engine not started position).

Not trying to argue, just letting you know I worked WITH their support and tried lots of different things they requested to try to get it to work.
They would really like to get a vehicle with the 6.0 to investigate the problem, so they can fix it.

I was really trying to keep the UG, I like the display and the price point
is fabulous. I guess I'll be getting a DashDaq for Christmas
(with GPS)

UG support has updated the "know compatibility issues" document
as follows:
(taken directly from their web-site)
1996-present Ford F250 and F350 Diesels may not support fuel and mileage gauges.. There is no clear pattern. Some work, others do not.
__________________
'05 EB Excursion 2wd 6.0 3.73/LS Mich LTX M/S2, Diesel Kleen (gray bottle), FICM w/atlas40 from Ed, RAS, Read Head Steering, scangaugeII w/Blendmount, '08+ Tow Mirrors, Magnefine PS filter, SPAtechnique Dual-Gauge (FP & Volt), Blue Spring, Air Lift 1000, Interior Dome Override, DieselSite Coolant Filter, BPD Oil & EGR coolers, Rancho RS9000, Hellwig, Diehard Platinum x2
Reply With Quote
Old 10-18-2010, 08:19 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.0L Power Stroke Diesel

Tags
60, address, company, deisels, f350, ford, gauge, guage, sensor, specifications, temperature, truck, ultra, ultragauge, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 08:14 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup